App is showing as incompatible

Sometimes after upgrading Jira instance, an app might be shown as incompatible and regular update procedure won’t work. It is caused by differences in JIRA Java API, so different Jira versions may require a different package of Secure Fields.

In order to fix it, you will have to uninstall the app manually and install the latest version by searching for Secure Fields in Find new apps section. All settings and license will remain unchanged.